Simulasi Jaringan di Virtualbox Ubuntu 10.04

Simulasi jaringan di virtualbox ubuntu 10.04

Virtualbox adalah software simulasi yang dapat kita gunakan untuk melakukan experimen jaringan. Hal ini sangat membantu bagi rekan2 yang ingin sekedar melakukan pembelajaran namun terkendala sarana peralatan. Di virtualbox sendiri kita dapat melakukan instalasi sistem operasi secara virtual yang disebut guest OS, sedang OS yang terinstall virtualbox disebut dengan Host os.

Di tutorial ini diasumsikan PC anda sudah terinstall virtualbox. Kita akan membuat jaringan seperti gb dibawag ini

virtualbox menyediakan fasilitas kartu jaringna virtual yang terdiri dari 3 macam:

    NAT : Tipe ini akan menyebabkan host virtual dapat melakukan ping ke host nyata dan tidak sebaliknya.
    Bridge : Tipe ini menyebabkan semua host baik host virtual maupun host nyata akan bisa saling ping (kita akan menggunakannya untuk menshare koneksi internet dari host ke guest).
    Internal Network : Tipe ini akan menyebabkan hanya host-host dilingkungan virtual saja yang bisa saling berkomunikasi (ping).

Langkah2:
1. install mikrotik di virtualbox, jika anda menggunakan sata maka harus memilih mikrotik 3 >. sedang untuk yang IDE bisa menggunakan versi 2.
2. install xp yang akan kita pakai sebagai client.

Saat ini saya terhubung dengan internet melalui wifi. Rencana saya akan menshare koneksi internet tsb melalui mikrotik sehingga client windows bisa mengakses internet. Setting kartu jaringan dan IP adalah:

Mikrotik:
Adapter 1 type: bridege, dan kita tujukan pada wlan0 yang terkoneksi internet.
Adapter 2 type: internal network, akan kita jadikan gateway LAN

XP:
Adapter 1 type: internal network

settingan mikrotik:
[admin@mikrotik]> interface set ether1 name=publik
[admin@mikrotik]> interface set ether2 name=lokal

[admin@mikrotik]> /ip address add address=192.168.1.1/24 interface=publik
[admin@mikrotik]> /ip address add address=192.168.10.1/24 interface=lokal

[admin@mikrotik]> ip route add gateway=192.168.1.254
ket: 192.168.1.254 adalah ip gateway di jaringan komputer host.

[admin@mikrotik]> ip dns set secondary-dns=111.26.68.165
[admin@mikrotik]> ip dns set secondary-dns=111.26.68.166

ket: setting dns tergantung dengan jaringan tempat anda

menambahkan NAT tujuanya agar paket dari client XP dapat diteruskan oleh router melalui interface publik
[admin@mikrotik] > ip firewall nat chain=srcnat action=masquerade src-address=192.168.10.0/24 out-interface=publik

coba ping gateway di jaringan real anda, punya saya 192.168.1.254

Jika sukses lanjut kelangkah berikutnya untk menyeting IP di guest XP. Jalankan xp bersamaan dengan mikrotik. berikan ip yang masih satu subnet dengan interface lokal, misal:
ip 192.168.10.11
gateway 192.168.10.1
dns 111.26.68.165

Sekarang coba lakukan ping dari XP ke interface mikrotik dan ke gateway jaringan host anda. Jika sukses sharing koneksi telah berhasil. Jika ada pertanyaan silahkan post.

About the author /


Setelah menamatkan pendidikan di Jogjakarta, selain aktif menulis di nahini sekarang sedang mengadu nasib di ibukota Jakarta sebagai salah satu tim IT Departemen Keuangan

No Comments

  1. EghyR01

    Terima Kasih Pak Atas tutorialnya ..
    artikel yang sangat bagus ..

Post your comments

Your email address will not be published. Required fields are marked *